Issue
Various issues have been observed regarding the use of the I/A Series R2 WorkPlace Pro or I/A Series G3 Graphics access. The following is a partial list of known issues caused by the Ethernet firewall built into the Trend Micro Internet Security Suite software:
- When attempting to install an R2 UNC license using the Admin Tool, the error "Unable to install license" is displayed.
- When attempting to connect to a UNC from the WorkPlace Pro tree, a "Cannot connect" error occurs.
- When attempting to access G3 graphics using the web browser, the user is unable to log into the station serving the graphics.
- When attempting to access R2 graphics using the web browser, the user is unable to display the graphics pages.
- When attempting to paste a .gif file to a UNC's remote library, WorkPlace Pro stops responding and must be closed with Windows Task Manager.
- When attempting to open a local station on the computer, using WorkPlace Pro, the Windows hourglass is displayed and the station never opens.
This list will be updated as additional issues are encountered.
Environment
Computer running "Trend Micro Internet Security Suite"
I/A Series R2 (Niagara) WorkPlace Pro software or attempting to use the computer to view I/A Series G3 (Niagara) graphics.
Cause
The I/A Series R2 software requires bi-directional communications over Ethernet port 80 unless the software has been user-configured to use a different Ethernet port.
The Trend Micro Internet Security Software Suite has a built-in firewall that blocks incoming access to Ethernet port 80. The Trend Micro software does not allow this port to be unblocked because it considers web access to a "workstation class" computer as a security risk.
Resolution
The best solution to this issue is to use a different Internet Security software package on the computer that does not block the use of Ethernet port 80. One approach is to use the "Server" version of Trend Micro Internet Security instead of the "Workstation" version. Since port 80 is typically used on server systems as the IIS (Internet Information Services) access port, the Server version of the software does not block that port.
The alternate solution is to configure the I/A Series R2/G3 (Niagara) software to use a different Ethernet port for HTTP communications and Web services. This change would need to be made in the R2 or G3 software installed on the computer as well as in every UNC or ENC being accessed from this computer.
See New installation of the I/A Series (Niagara) R2 WorkPlace Pro software cannot connect to existing UN... for more information.