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"Could not create remote directory" or "Failed to establish connection with the target device" when upgrading/downgrading a Xenta 5/7/9xx

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"Could not create remote directory" or "Failed to establish connection with the target device" when upgrading/downgrading a Xenta 5/7/9xx

Picard Product_Support
‎2018-12-02 04:25 PM

Last Updated: Administrator CraigEl Administrator ‎2022-08-08 05:54 PM

Warning

Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.

Issue

Error: "Could not create remote directory" or "Failed to establish connection with the target device" when trying to upgrade/downgrade a Xenta 5/7/9xx controller

WindowsUpdate1.png

 


Failed_to_establish_connection.png

 

Product Line

TAC INET, TAC Vista, Satchwell MicroNet

Environment

  • Xenta Servers
  • Xenta 511, 527, 527-NPR, 555, 701, 711, 721, 731, 913
  • XBuilder

Cause

This error can be caused by any of the following reasons:

  • Trying to downgrade a Hardware version 2.x Xenta Server device to System Program version 2.10 or older
  • Internet Options are configured to use a proxy server
  • IP communication is not properly established due to incorrect IP settings, a bad cable or a faulty device
  • The controller is 5.1.8 or lower and Microsoft KB 2661254 or KB 2661254-V2 is installed on the PC. In this upgrade Microsoft has changed the criteria for the certificate Key. Service packs are available on the extranet to correct this issue.
  • Download blocked because of other Windows updates
  • SSL 2 and 3 is not activated

Resolution

First, establish that the System Program that you are attempting to load is compatible with hardware version of the device. The older HW 1 versions can be upgraded to System Program 5.1.2 or older. Only system program versions 2.2.0 and newer can be loaded into devices that are hardware version 2.X.

Hardware Version System Program
1.0 5.1.2 or older
2.X 2.2.0 or newer
3.X 5.1.6 SP1 or newer

Note: Hardware version 1 devices are not labeled as HW 1 since only one version of hardware existed at the time. Hardware devices can be identified by the lack of any hardware version printed on the Neuron ID sticker.

Note: If running the firmware update software, ensure you are running as an administrator.

Next, check to verify that IP communications are configured properly and are functional:

  1. Check the IP address defined in XBuilder
  2. Verify a good connection to the IP port of the controller (10Base-T port on the far right) with a crossover cable.
  3. If that is all good, then a reformat of the controller may be necessary. Connect via Hyperterminal to the unit and at the dsh> prompt type format and press enter command . This will recreate the directory structure of the controller and allow you to attempt the upgrade/downgrade again.

Finally, verify that the Internet Options are not configured to use a proxy server or, if they are, temporarily change them as follows:

To temporarily change this setting follow these steps:

  1. In Internet Explorer select the Tools Menu and select Internet Options. Or select Internet Options from your Control Panel.
  2. Go to the Connections tab.
  3. Click the LAN settings button.
  4. Uncheck the Use a proxy server for your LAN box.
  5. Click Ok in the LAN settings window and the Internet Options window.
  6. Complete the System Program download.
  7. Return to the Internet Options window and re-check the Use a proxy server for your LAN box in the LAN Settings found in the Connections tab.

Another Matrix explaining the compatibility of each with Vista versions can be found in Xenta-Server-firmware-versus-Vista-Server-versions

If you have the Xenta FW 5.1.8 or lower and KB 2661254 or KB 2661254-V2 were installed during a Windows Update you will need install the service packs. These new service pack builds have been released and are available on the extranet. See TPA-VSTA-12-0028.00 - TAC Xenta Servers, Not Possible to Download Firmware for more info.

Another issue has been reported to support relating to the bit length of the Xenta server boot certificate. The Xenta server installer uses a 512 bit key length of the boot certificate, and Windows in some instances can be configured for a 1024 bit length certificate. If the issue still exists after removing the above mentioned Windows Updates, or if you are getting this error and the Windows Updates are not on your machine. Download the attached tool, Allow Weak Certificates.zip, and execute the file, chose "Allow Weak Certificates", and "Update".

WeakCert.png

 

Here is what the tool set:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\OID\EncodingType 0\CertDllCreateCertificateChainEngine\Config]
"EnableWeakSignatureFlags"=dword:00000002
"minRSAPubKeyBitLength"=dword:00000200

If taking the preceding steps fails to resolve the issue then see the following articles for additional steps that can be taken:

  • Xenta Server "Run" light is solid red, with no communication via Ethernet, 
  • Fail to upgrade the TAC Xenta Server system software (firmware) 
  • An unexpected error occurred while downloading using a Xenta Server
Labels (3)
Labels:
  • Satchwell MicroNet
  • TAC INET
  • TAC Vista
Attachments
Allow Weak Certificates.zip
Tags (6)
  • Find more articles tagged with:
  • 2857
  • does
  • domoport.xml
  • ldv.xml
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  • PeterLarsen21
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