Issue
Xenta 527 Appears offline: Troubleshooting steps.
Product Line
TAC INET
Environment
- I/NET
- Xenta 527
- Xenta 527-NPR
Cause
Possible Causes:
- Ethernet Communication is down
- Ethernet Port is closed
- Device is configured incorrectly
- Device failure
Resolution
Ethernet Communication is down
- Using the command prompt, ping the device's IP and trace its route. "ping (Insert IP Address)" and "tracert (Inset IP Address)" Watch to see if the Domain server prints out the correct Hostname. If the device is shown as offline, there may be an error with Firewall settings or Ethernet communication at the Host Workstation.
- Connect to the router via Internet Explorer
- If neither of these is possible, Communication is definitely down on the Workstation side. Next, check the Xenta Server side.
- Disconnect the Ethernet cable from the Device and plug it into a laptop. See if you are on the network.
Ethernet Port Is closed.
- If the above process shows that Ethernet communication between the Workstation and Router is valid, you may have the port closed.
- Use a crossover cable to connect a laptop to the device and see if you can connect to a controller ON THAT LINK in I/NET. Look for live values in Controller Summary.
- If you can do this, and you can show that Ethernet communication between the two devices is working, then you most likely have a firewall on port 50069
- Contact the building IT department
Device is configured incorrectly
- If, in the above process, you cannot connect to I/NET while directly connected to the Router via an Ethernet crossover cable, the device may be configured incorrectly.
- Open the active I/NET configuration Profile.
- Ensure that TCP/IP is enabled
- Add the Router’s IP address to the Reference Host Table
- Restart the I/O server
- Check communication
- Connect to the 527 via HyperTerminal
- type setip and verify you have been using the correct IP address and hostname
- type inethost and add the Workstation’s IP address to the Reference host table.
- restart the 527
- Communication should be restored.
Device failure
- Observe the "Run" light on the device. It should be solid green.
- Observe the TCP/IP port LED. If you are actively communicating, this should be blinking.
- If you are unable to connect to the device via a HyperTerminal Direct Connection or Internet explorer while directly connected, you may have a device failure
- Cycle Power on the device
- Connect via HyperTerminal (if you cannot do this, try using the failsafe mode. If that fails, replace the device)
- Type the command “format” to format the device
- type “setip” and enter the IP information
- Download and install the latest system file for the 527 you are using. Remember that the 527 and the 527-NPR use different install files.
- Configure the I/NET communication in HyperTerminal
Other Troubleshooting Steps
- See if the communication error shows up on multiple computers and, if possible multiple locations. There may be an error with Firewall settings or Ethernet communication that only affects part of a large system Host Workstation.
- Use a different Ethernet port to connect the 527 or workstation to
- Direct connect to a controller on the controller LAN via TAP and see if any stations are offline. It is theoretically possible that some form of electrical failure on the controller LAN has caused the 527 to appear offline. If you cannot see the entire controller LAN from anyone on one device, you should troubleshoot Controller LAN communication.
If this is a recurring issue for the site, please download and use the attached 527 offline response document for information gathering and troubleshooting.