Issue
After upgrading a TAC Vista system on a site with high IT security you can end up with a wrong schema version in the SQL database causing issues such as failure to insert trend log data.
Environment
TAC Vista
SQL
Cause
In some versions of TAC Vista, the SQL database upgrade carried out during the installation of TAC Vista doesn't upgrade the SQL database to the newest version. The first time you start TAC Vista Server, the server (TACOS) carries out the remaining upgrade steps.
On a site with very high security standards, TAC Vista Server is however not able to apply the last SQL database upgrade scripts as those can only be carried out by the IT department directly on the SQL server, and as a result the SQL database is not fully upgraded.
Resolution
1. Note exactly what schema version the SQL database currently has
This can be checked through SQL management studio with this query
USE taclogdata;
SELECT dbo.DSS_SchemaVersion() AS Db_SchemaVersion
2. Note exactly what version of TAC Vista you have upgraded to
3. Contact PSS to get a SQL upgrade script specific for the site and run that on the SQL database