Issue
What is the recommended method to upgrade a Niagara R2 station to a newer version?
Product Line
TAC IA Series
Environment
I/A Series Niagara R2
Cause
Unsure how to upgrade station databases.
Resolution
The published upgrade procedure is provided in F-27334. Below is a modified method that also works. Doing station upgrades on the server first is preferred. If there are any errors, they can be addressed without operational interruptions.
- Using the existing version of WorkPlace Pro (WPP), backup ALL of the UNC and Server databases into XML format.
- Methods of backing up and converting databases.
- Open the Enterprise server in WorkPlace Pro. Double click the station name. Select "Commands" and "Backup XML to save the server in XML. Then select "Backup Subordinate XML" to pull all of the UNC databases as XML into the server stations folder.
- If not on site but the UNC and Server databases are available, use the DB Admin tab of the Admin tool to convert the databases locally to XML.
- Open the Enterprise server in WorkPlace Pro. Double click the station name. Select "Commands" and "Backup XML to save the server in XML. Then select "Backup Subordinate XML" to pull all of the UNC databases as XML into the server stations folder.
- Methods of backing up and converting databases.
- Now install the newer Niagara revision onto the Server.
- Copy the stations containing the XML files to the desired WPP revision station folder.
- Enable and open the new revision of WPP.
- Use the Admin Tool to convert locally all of the stations from XML to DB. (If there are any errors, they can be addressed without affecting the running installation.)
- After all the databases have successfully converted to DB, convert them to SNS. (This saves time later if the UNCs need reloading)
- Use the Enterprise Server to upgrade the UNC. During the upgrade process of the UNC it will ask to backup the database. If the database had upgraded with no issue in the previous step, enter the username and password to proceed with this backup. This will backup the station, upgrade the UNC, and then upgrade and reinstall the station. The previous station upgrade will be needed only if there is an issue.
If after following this procedure the station still fails to start, contact Product Support Services.