Issue
- Reporting Agent continuously restarts
- Windows Event logs show appcrash for Reporting Service
- Trend / Event data no longer transferring to WebReports / Report Server.
Product Line
EcoStruxure Building Operation
Environment
Building Operation Report Server
Cause
If there are bindings within the Extended Trend Log that is from itself (so a cyclic loop).
By default when you select the Transfer trigger variable the SmartLog property is selected (as shown below). This is an invalid configuration but can be accidentally configured and saved.
This will cause the ES read to go into an infinite loop and cause the application to eventually restart (crash). By setting the Reporting Agent to Debug (using the SBO Reports Agent Config - Communities (se.com)) the last few messages before the restart within the log file will show messages related to "Entering IncludeLogInReports()" with the same set of Extended trend Logs repeat (if there is more than one).
The image below shows an example of the Extended Trend Log shown in the above screenshot.
Resolution
After locating the relevant extended trend logs with these invalid bindings, delete these invalid bindings and restart the Reporting Agent service and the data should then be read correctly.
Remember to revert the log level back to INFO before restarting the agent to not overload the logs with too much detail.