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WebReport login errors.

Picard Product_Support
‎2018-09-10 08:16 PM

Last Updated: Guinan RobertAndriolo Guinan ‎2021-07-22 06:24 PM

Issue

  • Receive an error: "The user session is lost, no specific reason has been set." when logging into StruxureWare Building Operation WebReports from Internet Explorer (browser), while Reports from within Workstation work fine. 
  • Receive an error: "The user session is lost, no specific reason has been set." when logging into StruxureWare Building Operation WebReports from Internet Explorer (browser), and get no Reports folder within Workstation.
    Error.png
  • Login Screen appears as expected, but when attempting to log in with the user name/password; It times out and comes with the message 'Failed to establish connection with server.'

Product Line

EcoStruxure Building Operation

Environment

Building Operation WebReports 1.1 / 1.2

Cause

The error is most likely due to ports been blocked and/or the incorrect port settings entered during the WebReports installation process. When installing (or upgrading) WebReports, you must enter this information on each occasion as this information is not retained from previous installations.

If you need to change these settings, then you should follow the procedure detailed below.

Resolution

If installed on separate machines, then check the firewall settings and ensure the ports used for the Enterprise Server and the Report Server are not blocked. 

If this does not resolve the issue or if you are running both the Enterprise Server and Report Server on the same PC, then the Enterprise Server port configuration during the WebReports installation may need to be changed.  This is achieved as follows: this, and follow these key steps:

  1. Run the WebReports Installation setup program, and at the Setup Type prompt, select Upgrade from...
    WebReportsInstaller_UPgrade.png
  2. Proceed through the other options as normal. Once you reach the Reporting Agent setup, make sure you enter the correct URL (path and port number - this is unique for each installation) used during the Enterprise Server setup.
    ReportAgentCorrectESURL.png
  3. Continue through the other settings as required - Ensure that any Path and URL ports are set correctly.  Once you complete these settings, the WebReports Installer package then goes through the following checks and installation:
    • Checking Installation Requirements
    • Pre-upgrade Configuration
    • Installation of Reporting Agent, WebReports, and WebReports Service
    • Post-Installation Configuration
    • Installation PublishedReports
  4. After the above steps, the upgrade is completed. This will now allow login to the WebReports URL using your web browser.

For additional assistance in installing/upgrading WebReports, refer to the online help website. 

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