Issue
There was a problem with the SQL server and the logs and events were queued in the $Queues folder. The SQL problem is resolved but the $Queues folder has grown so much that it can't be opened to check.
Is there a way of checking if Vista has restarted logging to SQL?
Product Line
TAC Vista
Environment
- TAC Vista Server
- Microsoft SQL Server
Cause
When a problem occurs with the SQL server, the log values and events are saved in the $Queues folder in the TAC Vista database, so that no information is lost. As long as there is no connection to SQL, the logs and events will be queued in $Queues. Once a connection to SQL is re-established, Vista will start logging all the values in the $Queues folder, gradually emptying the folders, although this may take some time if the SQL server has been down for a while.
Resolution
Query the SQL database and check for logs with today's date.
- Download & install Microsoft SQL management studio (2005 or 2008 depending on which version of SQL is being used)
- Query the trend log table for logs using the following query:
- Start SQL management studio and log in to the TACVISTA sql instance.
- Click on New Query and type in the following query:
use taclogdata
go
select *
from TrendLogValue
where LogTime > '2011-11-03 00:00:00.000'
Note: if you have a custom configured SQL database change taclogdata to your database name.
-Change the date to today's date and execute the query. If the query doesn't return any matches, change the date to an earlier date and repeat.
-Keep going until the date when contact with SQL was lost.
If no matches are returned, check that the service TAC DSS writer is running. If it is then it maybe that the Vista is till trying to clear the backlog. Try again later.