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Upgraded database fails to download to AS-P / AS-B Servers

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Upgraded database fails to download to AS-P / AS-B Servers

Guinan RobertAndriolo Guinan
‎2025-08-05 10:47 PM

on ‎2025-08-05 10:47 PM

Issue

After performing server upgrades using Device Administrator, attempts to download the database fail. The server remains in a "Ready for download" state, which cannot be cleared.

 

Device Administrator Download Fail errorDevice Administrator Download Fail error

Product Line

EcoStruxure Building Operation

Environment

  • Building Operation Device Administrator
  • Building Operation Automation Server Premium
  • Building Operation Automation Server Bundled
  • Building Operation Automation Server.
  • Building Operation 2023 (version 5) and above

Cause

This happens when a Consolidation Point (CP) or Hotfix has been applied. These updates do not include server packages in Device Administrator, causing download failures during post-hotfix upgrades.  DFU upgrades and base version upgrades of the installed Device Administrator still function as expected.

Resolution

This issue is cosmetic and does not impact server functionality, there’s no operational need to upgrade servers after applying a hotfix or CP. However, to clear the persistent "Ready for download" state:

  1. Navigate to:

    C:\ProgramData\Schneider Electric EcoStruxure\Building Operation x.0\Device Administrator
    
  2. Locate the folder:

    • Find the folder named tmp[SerialNumber] (e.g., tmpSM22111234) that correlates to the server(s) showing the state "Ready for download"
  3. Delete all files inside that folder.

  4. Restart Device Administrator if it’s open.

This will clear the "Ready for download" status.

 

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