Issue
During an Enterprise Central or Enterprise Server upgrade, the upgrade is halted with a message that the "server has not stopped".
"Error: server state 'ServerShuttin'"
Upgrade Fails on Server not stopped state = starting
Product Line
EcoStruxure Building Operation
Environment
- Building Operation Enterprise Server
- Building Operation Enterprise Central
Cause
If the last shutdown of the ES/EC process was due to a crash or if it was stopped through the task manager, the current ES/EC server state is not updated, causing the upgrade to fail.
Resolution
- Check that the server process is stopped: SE.SBO.EnterpriseServer.exe or SE.SBO.EnterpriseCentral.exe in the Task Manager.
- Open the database folder for the server in question, e.g., %programdata%\Schneider Electric EcoStruxure\Building Operation 3.2\db
- Edit the file: nsp_servers.serverstate
- Change the text "ServerShuttin" or "ServerRunning" to "ServerStopped".
- Save the file and try again (retry)