Issue
Uninstall Process for Web Reports
Product Line
EcoStruxure Building Operation
Environment
- SmartStruxure Web Reports Server
- StruxureWare for Building Operation Web Reports Server
Cause
After a re-install of webreports, certain features will not function if the original version was not completely removed.
Resolution
To uninstall WebReports:
- In Windows Control Panel, point to Programs and then select Uninstall a Program.
- Right-click StruxureWare Report Pack Installer and then click Uninstall.
- Right-click StruxureWare Reporting Agent and then click Uninstall.
- Right-click StruxureWare Reports Installation and then click Uninstall.
- Right-click StruxureWare WebReports and then click Uninstall.
- Right-click StruxureWare WebReports Service and then click Uninstall.
- In your Web browser, type the URL for SQL Server Reporting Services Report Manager. If you have installed SQL Server 2008 R2 Express, the URL is http://localhost/reports_sqlexpress
- Click Details View.
- Select the folders that contain the WebReports reports including Data Sources.
- Click Delete.
- Click OK.
- Click Close.
- Open Microsoft SQL Server Management Studio (type SQL in the Start menu Search box).
- Expand the Databases folder.
- Right-click StruxureWareReportsDB and then click Delete.
- In the Delete Object window, select StruxureWareReportsDB.
- Select Close existing connections.
- Click OK.
- Open Internet Information Services (IIS) Manager (type IIS in the Start menu Search box).
- In the Connections pane, expand Sites, expand Default Web Site, and then expand SchneiderElectric.
- Delete each virtual directory in the specified order:
- Right-click WebReportsService and then click Remove.
- Right-click WebReports and then click Remove.
- Right-click SchneiderElectric and then click Remove. - - In the Connections pane, select Application Pools.
- Right-click SchneiderElectric.WebReportsAppPool and then click Remove.
- Right-click SchneiderElectric.WebReportsServiceAppPool and then click Remove.
- Exit Internet Information Services (IIS) Manager.
- In SQL Server Reporting Services Report Manager (see previous steps), click Folder Settings.
- Select the NT AUTHORITY\IUSR check box and the [PC NAME] \appuser check box, and then click Delete.
- Exit SQL Server Reporting Services Report Manager.
- In Windows Control Panel, select System and Security, then select Administrative Tools.
- In Computer Management, expand Local Users and Groups and then select Users.
- Right-click appuser and click Delete, then follow any further prompts to complete the deletion.
- In Microsoft SQL Server Management Studio, expand Security and then expand Logins.
- Right-click the appuser account and then click Delete.
- In the Delete Object window, select appuser.
- Click OK.
- Click OK again.
- Right-click NT AUTHORITY\IUSR and delete it in the same way as you deleted the previous (appuser) account.
- Right-click [PC NAME] \appuser and delete it in the same way as you deleted the previous (appuser) account.
- Exit SQL Server Management Studio.
- In Windows Explorer, expand Program Files (x86) and then expand Schneider Electric.
- Right-click StruxureWare Reports Installation and then click Delete.
- Right-click StruxureWareReports and click Delete, then follow any further prompts to complete deletion.