Issue
Unable to display Traditional Chinese characters in Workbench graphics and Alarm Portal
Product Line
TAC IA Series
Environment
I/A Series G3 version 3.7 and 3.8
Cause
There was change between I/A Series G3 version 3.6 and 3.7. A lexicon tool was added so that the user could use a default set of lexicons (modules). This is a change in the implantation of lexicons in I/A Series G3.
The issue was that the default lexicon module for (zh) did not include the font parameters causing the software to not know how to display the Unicode characters.
Resolution
The I/A Series lexicon tool can be used to build and enhance the module by the user for deployment on sites. In addition, the I/A Series G3 still supports the use of the previous mechanism that used lexicon files. The lexicon file basically overrides the default module.
- Copy the lexicon zh folder from I/A Series G3 3.6 (\niagara\niagara-3.6.xxx\lexicon\)
- Create a lexicon folder under '\niagara\niagara-3.7.xxx\' in I/A Series 3.7 (or 3.8) and add zh folder copied in step1.
- Exit the Alarm Portal, stop the station and close Workbench.
- Update the system.properties file (see below) which is located in '\niagara\niagara-3.7.xxx\lib\'. Change the field to 'niagara,lang=zh' and save.
# This system property is used to override the the default locale. # If not specified, then the VM will attempt to use a default based # on the current operating system settings. This value should map # to a lexicon directory. niagara.lang=zh
Launch Workbench and Alarm Portal and verify that the issue has been resolved.