Issue
Unable to connect to the detected RPCs using Engage app v1.2.1 or later and RPC 3.02.01
Product Line
EcoStruxure Building Operation
Environment
- Building Operation Room Controller (RPC) (all types) v3.02.01
- Building Operation Engage Application
Cause
EFR32 BLE chip needs to be upgraded to fw3.01.00.00012 but looking at the device report you see there is a Failure to upgrade EFR32 error.
Resolution
- From workstation open the control panel and select the Firmware upgrade view.
- Right-click the RPC from the list of available SmartX controllers > Device> Upgrade Firmware>Select Device Firmware
- Select 3.01.02.00046 Firmware package
- Wait for the RPC to fully upgrade and return to an online state before going to the next step. This may take 6 to 9 mins which is normal.
- Right-click the RPC from the list of available SmartX controllers > Device> Upgrade Firmware>Select Device Firmware
- Select 3.02.01.00247 Firmware package
- Wait for the RPC to fully upgrade and return to an online state before going to the next step. This may take 6 to 9 mins which is normal
- Once the RPC is online Right Click the RPC > Device> Download All Objects
- If not upgraded in this order, the Bluetooth Chip isn't correctly upgraded and will fail.