Help
  • Explore Community
  • Get Started
  • Ask the Community
  • How-To & Best Practices
  • Contact Support
Notifications
Login / Register
Community
Community
Notifications
close
  • Forums
  • Knowledge Center
  • Events & Webinars
  • Ideas
  • Blogs
Help
Help
  • Explore Community
  • Get Started
  • Ask the Community
  • How-To & Best Practices
  • Contact Support
Login / Register
Sustainability
Sustainability

Join our "Ask Me About" community webinar on May 20th at 9 AM CET and 5 PM CET to explore cybersecurity and monitoring for Data Center and edge IT. Learn about market trends, cutting-edge technologies, and best practices from industry experts.
Register and secure your Critical IT infrastructure

Troubleshooting "4417 DEVICE_ERR_NOADDR_I2C" errors seen in Controller's Error Log.

Building Automation Knowledge Base

Schneider Electric Building Automation Knowledge Base is a self-service resource to answer all your questions about EcoStruxure Building suite, Andover Continuum, Satchwell, TAC…

cancel
Turn on suggestions
Auto-suggest helps you quickly narrow down your search results by suggesting possible matches as you type.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
  • Home
  • Schneider Electric Community
  • Knowledge Center
  • Building Automation Knowledge Base
  • Troubleshooting "4417 DEVICE_ERR_NOADDR_I2C" errors seen in Controller's Error Log.
Options
  • Bookmark
  • Subscribe
  • Email to a Friend
  • Printer Friendly Page
  • Report Inappropriate Content
Invite a Co-worker
Send a co-worker an invite to the portal.Just enter their email address and we'll connect them to register. After joining, they will belong to the same company.
You have entered an invalid email address. Please re-enter the email address.
This co-worker has already been invited to the Exchange portal. Please invite another co-worker.
Please enter email address
Send Invite Cancel
Invitation Sent
Your invitation was sent.Thanks for sharing Exchange with your co-worker.
Send New Invite Close

Related Forums

  • Intelligent Devices Forum

Previous Next
Contributors
  • AdamSteele
    AdamSteele
  • Product_Support
    Product_Support

Invite a Colleague

Found this content useful? Share it with a Colleague!

Invite a Colleague Invite
Back to Building Automation Knowledge Base
Options
  • Bookmark
  • Subscribe
  • Email to a Friend
  • Printer Friendly Page
  • Report Inappropriate Content
0 Likes
1675 Views

Link copied. Please paste this link to share this article on your social media post.

Trying to translate this page to your language?
Select your language from the translate dropdown in the upper right. arrow
Translate to: English
  • (Français) French
  • (Deutsche) German
  • (Italiano) Italian
  • (Português) Portuguese
  • (Русский) Russian
  • (Español) Spanish

Troubleshooting "4417 DEVICE_ERR_NOADDR_I2C" errors seen in Controller's Error Log.

Picard Product_Support
‎2018-09-06 09:31 AM

Issue

Troubleshooting 4417 DEVICE_ERR_NOADDR_I2C errors seen in Controller's Error Log.

Environment

Continuum Controllers

Cause

0x00004417 0x00002100 0x021046e2 0x00080002 0x000000200x00004417 0x00002100 0x021046e2 0x00080002 0x00000020
"DEVICE_ERR_NOADDR_I2C" errors are related to the internal bus to the peripherals and RealTimeClock.
 
DEVICE_ERR_NOADDR_I2C       (no address response)
    
“DEVICE_ERR_NOADDR_I2C” errors are not I2 errors they are I2C errors. These errors are related to the internal bus to the peripherals (like an onboard RealTimeClock or the expansion bus (modules)).
 
There may have been an expansion module installed that has been removed while a PE program is still accessing an I/O on the module.

Resolution

Possible causes can be:
 
1. A defect with the onboard RealTimeClock. Check for 4417 errors followed by TimeSync errors and/or indications that the time clock is not stable similar to the following error lines.
 
01/01/1989 00:00:00.00 0x00004417 DEVICE_ERR_NOADDR_I2C (no address response)
01/01/1989 00:00:00.00 0x00010000 Clock change
 
2. An issue with the expansion bus modules. There may have been an expansion module installed that has been removed while a PE program is still accessing an I/O on the module.
Labels (1)
Labels:
  • Andover Continuum
Tags (4)
  • Find more articles tagged with:
  • 10000
  • 16393
  • 4417
  • clock
Was this article helpful? Yes No
No ratings

Link copied. Please paste this link to share this article on your social media post.

To The Top!

Forums

  • APC UPS Data Center Backup Solutions
  • EcoStruxure IT
  • EcoStruxure Geo SCADA Expert
  • Metering & Power Quality
  • Schneider Electric Wiser

Knowledge Center

Events & webinars

Ideas

Blogs

Get Started

  • Ask the Community
  • Community Guidelines
  • Community User Guide
  • How-To & Best Practice
  • Experts Leaderboard
  • Contact Support
Brand-Logo
Subscribing is a smart move!
You can subscribe to this board after you log in or create your free account.
Forum-Icon

Create your free account or log in to subscribe to the board - and gain access to more than 10,000+ support articles along with insights from experts and peers.

Register today for FREE

Register Now

Already have an account? Login

Terms & Conditions Privacy Notice Change your Cookie Settings © 2025 Schneider Electric

This is a heading

With achievable small steps, users progress and continually feel satisfaction in task accomplishment.

Usetiful Onboarding Checklist remembers the progress of every user, allowing them to take bite-sized journeys and continue where they left.

of