Issue
Communication failures with Microsmart controllers on the DMS bus network.
Product Line
TAC IA SeriesEnvironment
Microsmart controllers (all models installed with revision 9.x, 10.x, or 11.x firmware)
Cause
Common causes include:
- Incorrect power supply wiring or insufficient voltage
- Shared power between controllers and field devices
- Exceeding maximum controller count per RS-485 segment
- Improper network topology or cable type
- Missing or incorrectly installed End-of-Line (EOL) modules
- Ground loops or shield continuity issues
- Duplicate or illegal point names in controller database
- Faulty line drivers or incorrect address switch settings
Resolution
The following checklist provides several settings/configurations to review when faced with a communication problem at the controller level. The content was compiled from different resources, summarized, and laid out in an easy-to-use manner so as to provide a quick-reference document.
Do all controllers have a power supply?
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ACTION: Confirm with a voltmeter.
Confirm power (VA) requirements.
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Do the affected controllers share a common
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ACTION: (see installation instructions) |
| Do the affected controllers share a common power supply with output field devices?
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ACTION: Review controller and field device power wiring (see installation instructions) In addition, avoid wiring any half-wave and fullwave powered devices to the same transformer. |
How many MicroSmart controllers exist?
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ACTION: Determine controller count
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Any repeaters installed?
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ACTION: Identify model number
(Part# E21-1144) |
| How rapidly is the Watch Dog Timer (WDT) LED blinking?
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ACTION: Review LED activity
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| What is the length and topology of the controller trunk?
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ACTION: Review the following:
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| What is the condition of the controller database? | ACTION: Review the controller database
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Will Operator Interface (Part# PS-OPRIF) communicate to the controller?
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ACTION:
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