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Troubleshooting INET Ethernet (TCP/IP) communication problems with an NPR

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Troubleshooting INET Ethernet (TCP/IP) communication problems with an NPR

Picard Product_Support
‎2018-09-06 10:49 PM

Last Updated: Administrator CraigEl Administrator ‎2022-08-08 07:38 PM

Issue

Where to begin troubleshooting Ethernet (TCP/IP) communication problems with a NPR

Product Line

TAC INET

Environment

  • I/NET
  • NetPlus Router (NPR) Model Series 2000

Cause

Possible Causes:

  • Ethernet Communication is down
  • Ethernet Port is closed
  • Device is configured incorrectly
  • Device failure

Resolution

Gather detailed information about exactly what is happening

Ethernet Communication is down

  • Using the command prompt ping the devices IP and trace its route. "ping xxx.xxx.xxx.xxx" and "tracert xxx.xxx.xxx.xxx" Watch to see if the Domain server prints out the correct Host name. If the device is shows as offline there may be an error with Firewall settings or Ethernet communication at the Host Workstation
  • Disconnect the Ethernet cable from the Device and plug it into a laptop. See if you are on the network.

Ethernet Port Is closed

  • If the above process shows that Ethernet communication between the Workstation and Router is valid, you may have port closed.
  • Use a crossover cable to connect a laptop to the device and see if you can connect to a controller ON THAT LINK in I/NET. Look for live values in Controller Summary.
  • If you are able to do this, and you are able to show that Ethernet communication between the 2 devices is working then you most likely have a firewall that is block the UDP port 50069
  • Contact the building IT department to assist in rectifying this problem.

Device is configured incorrectly

  • If, in the above process, you were unable to connect to I/NET while direct connected to the Router via an Ethernet crossover cable, the device may be configured incorrectly
  • Open the active I/NET configuration Profile
  • Ensure that TCP/IP is enabled
  • Add the Router’s IP address to the Reference Host Table
  • Restart the I/O server
  • Check communication
  • Alternatively you can connect to the router via I/NET Direct Connect configuration profile. Refer to Troubleshoot an NPR problem with Windows Telnet utility on how to do this and check that the IP Address and details are set correctly.
  • Communication should be restored.

Device failure

  • Try to reset the NPR:
    1. Remove the NPR cover.
    2. Depress the center tab of the I/DISC slot and hold it down.
    3. Next press the reset button on the front of the unit and hold for 10 seconds.
    4. Release the reset button and then release the center tab.
    5. Two LEDs should display steadily.
    6. Next depress the center tab and hold it down.
    7. Press the reset button on the front of the unit and hold for 10 seconds.
    8. Release the center tab and reset button simultaneously.
    9. The LEDs should display steadily.
    10. The NPR unit should now be ready for a software restore.
  • Download and install the latest system file for the NPR.
  • Configure the I/NET communication in your active Configuration Profile.
  • If you not able to successfully update the firmware in the NPR then it is likely that the device is faulty and may require repair or replacement.  The current replacement for the Series 2000 NPR is the Xenta 527-NPR.

Other Troubleshooting Steps

  • See if the communication error shows up on multiple computers and if possible multiple locations. There may be an error with Firewall settings or Ethernet communication that only effects part of a large system Host Workstation
  • Use a different Ethernet port to connect the NPR or workstation too.
  • Direct connect to a controller on the controller LAN via TAP and see if any stations are offline. It is theoretically possible that some form of electrical failure on the controller LAN has caused the NPR to appear offline. If you are unable to see the entire controller LAN from anyone one device, you should troubleshoot Controller LAN communication.

Contact Product Support with your findings.

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