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The system is not open. (Subsystem: LNS, #67)

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The system is not open. (Subsystem: LNS, #67)

Picard Product_Support
‎2018-09-07 04:06 AM

Last Updated: Administrator CraigEl Administrator ‎2022-08-10 01:38 AM

Issue

A service that requires the system to be open has been accessed prior to successfully opening the System object.

TAC Vista System Plug-In
The system is not open. (Subsystem: LNS, #67)

Error: LNS #67 lcaErrSystemNotOpen

Product Line

TAC Vista

Environment

LonMaker
Vista
LNS

Cause

There are many circumstances that could cause this. For example, if you call the Validate method to validate a network database before opening the system, or if you call the Backup method to copy a network database before opening the system, this exception will be thrown.

Resolution

If registering or launching the TAC System Plug-in results in the error "System is not open, LNS #67" followed by "TACOSSysPin.Document launch failure Exception occurred," and "lnsplugin.api launch failure," then your LNS credits may be corrupted despite indications that they are not.  First reboot and try again.  If still fails, replacement credits have to be reordered from Echelon.  See description of LNS #147 in Error message in Vista System Plug-in: LNS System access failure, (Subsystem: NS,#147).

It is also possible to get LNS #67 without having corrupted credits.  This has been seen a couple of times on databases that are upgraded from LNS 3.1 to LNS Turbo.  It seems to be hit or miss whether the upgrade will cause this issue or not.  The Licensing Upgrade 2006 discussed in LNS #147 should be installed.  Defragmenting the computer can also cause this corrupted credits with no indication and a TACOSSysPin error. Replacement credits will fix the issue even though there is no indication that they are corrupted.

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