Issue
System changes made to a Security Expert server can cause the license to fail.
Product Line
EcoStruxure Security Expert
Environment
Security Expert licensing
Cause
When the SSN license is activated on the Security Expert server a hardware footprint of the server system is created and stored with the license activation. This ties the license to that specific machine, if the hardware footprint changes in the future this will break the license activation.
There may be additional system changes that trigger this but the ones we are aware of that will break the licensed hardware footprint are the following:
- A change of the Security Expert servers computer name.
- Normally when we see this the installer is attempting to activate/update the license from a Security Expert client machine instead of the Security Expert server machine.
- A change in the Network Interface Cards.
- Changing from a wired to wifi connection can potentially do this.
- If the server is installed on a virtual machine ensure that the Network Interface Card is assigned a static MAC address.
- Other hardware changes such as changing Hard Drives, CPU, Memory, Operating System or Motherboards.
Resolution
If the hardware footprint has changed, breaking the license activation, the SSN will need to be reset and an activation added.
- Contact your local support to add a registration to the license and clear the hardware profile.
- The installer will then do a License Update from the Security Expert server to re-activate the SSN.