Issue
- After configuration, Suprema readers are showing as offline in the Security Expert client.
- There are Security Expert Download Service events logged in the windows application event log.
- Cannot load DLL - LoadLibrary() Failed.
Product Line
EcoStruxure Security Expert
Environment
- Security Expert
- Suprema biometric readers
Cause
Required DLL SecurityExpertSV2.ThirdParty.dll is missing from the installation folder. Some versions of Security Expert installer will not install this required DLL and the file need to be manually added.
Resolution
Check the Security Expert install folder, typically C:\Program Files (x86)\Schneider Electric\Security Expert, to confirm if the file SecurityExpertSV2.ThirdParty.dll is present.
If the file is not in the installation folder then it can be sourced from the integration guide ZIP package. AN 264 Security Expert - Suprema Biometric - Integration Guide contains the three DLL's required for the integration. Install the file by copying it into the installation folder, then restart all of the Security Expert services or restart the Security Expert server.