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StruxureWare Building Operation Enterprise Server Application Error occurs at computer start up

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StruxureWare Building Operation Enterprise Server Application Error occurs at computer start up

Picard Product_Support
‎2018-09-06 11:55 AM

Issue

The ES crashes during startup
 
  • SE.EnterpriseServer.exe - Application Error occurs, and the Building Operation Enterprise Server service cannot be started. 
  • Error contains "The memory could not "written"".

 

The port fields in software administrator shows a red indication on one or more of the ports

Environment

Enterprise Server

Software Administrator

IP ports

Cause

A program is already using the ports defined for the Enterprise Server
 
 
In general
 
You can check which program it is, by entering the following command in a command prompt, replacing ":port number" with the number you want to check, e.g. "0.0.0.0:80" for port 80: netstat -aonb | find "0.0.0.0:port number"
 
 
Now in the task manager, enable the coloumn "PID (Process Identifier)", and look for the process ID you get to the far right when running the command above. That will show what program is taking the port.
 
 
 
Skype
 
If you are running Skype on the Enterprise Server PC there could be a conflict between the default IP port settings and the IP port settings in Software Administrator. The default ports for SmartStruxure Enterprise Server are 80 and 443. By default, Skype will "use port 80 and 443 as alternatives for incoming connections" if the configured port is unavailable. When Skype is launched it appears to search for an open IP port. If it cannot find an open port within a period of time it may default to ports 80 and 443 as a backup. This behaviour appears to be intermittent. 

 

TeamViewer

In newer versions of TeamViewer this is no longer an issue, but it's good practice to select "Use UDP" in the advanced settings of TeamViewer

Resolution

In general, you can change the ports used by the Enterprise Server in the Building Operation Software Administrator.

 

If the issue is Skype do the following:

  1. In the Skype tools menu go to “Options…”
  2. Expand the “Advanced” settings on the left hand side.
  3. Click “Connection” in the Advanced section.
  4. Uncheck the setting that says "Use port 80 and 443 as alternatives for incoming connections"

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