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SmartStruxure Hotfix file verifications

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SmartStruxure Hotfix file verifications

Picard Product_Support
‎2018-09-11 04:02 AM

Issue

  • Hotfix readme / report asks me to "Confirm the file versions are now build x.x.x.xxxx in explorer" - how is this done?

Environment

SmartStruxure Hotfix releases.

Cause

The 'File version' property on some files are not easily found / shown in Windows explorer, so only the 'date modified' can be used to indicate that the file has been updated. 

Resolution

The easiest method of confirming that files have been updated correctly by the Hotfix is to view them in Windows Explorer.  The paths for this are as shown below:

For versions 1.2 and below:

  • C:\Program Files\Schneider Electric\StruxureWare X.X\...(32-bit operating systems)
  • C:\Program Files (x86)\Schneider Electric\StruxureWare X.X\...(64-bit operating systems)

For versions 1.3 and above:

  • C:\Program Files\Schneider Electric StruxureWare\Building Operation X.X\...(32-bit operating systems)
  • C:\Program Files (x86)\Schneider Electric StruxureWare\Building Operation X.X\...(64-bit operating systems)

Within this path are the folders containing the files for each of the applications such as the Device Administrator, Enterprise Server, Workstation, etc as shown below.

  • For each Hotfix .EXE file that is applied you need to check each of these folders with the files detailed in the Hotfix readme / Hotfix Report provided.
  • To confirm that these files have been updated you can either check the File version shown in the properties of the file or you can display the file version as a column in Windows Explorer. See an example of this below (This is showing Hotfix 1.2.0.2207).
  • For the files that do not display their 'File version' property the only way to check that these have been updated is to look at the 'Date Modified' property. This date should match the date of the Hotfix application (.exe). See image below where these matching dates have been highlighted.

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