Issue
What is the best way to retrieve Logged data.
Environment
Logged data
Logging
Log retrieval
Cause
Sigma logged data is not always available to view, what is the best way to retrieve logged data from the Sigma controllers?
Resolution
Sigma controllers and IC's have the ability to upload logged data to the Sigma server when required, this is carried out when the controller data tracks are a certain percentage full. This is the best way of retrieving logged data. However this can be random and there will be occasions when a user wishes to see data that has not yet been uploaded.
If the user wishes to retrieve logged data from the controllers, there are two methods that can be used.
1 -The first method is to manually instruct the controller to upload its logged data.
- Using "System Diagnostics" select the required controller, and from the "Options" menu choose to upload "All Logged data" or "Selected Logged data". This action will return the data, which can then be reviewed.
2 - The second method is to create a scheduled retrieval.
- Enter "System Setup" and choose "Scheduled Actions". This option allows you to set the time that action occurs and can specify which controllers are affected.
- Select "Actions" and add a new one.
- The screen shot below shows that "Retrieve Controller Logs" has been selected, and this will apply to "All Controllers"
- Depending on the number of controllers present on this site, it may be better to retrieve the logs from groups of controllers at a time. The screen shot below shows the configuration for controllers 1-20.
- Having created the action, a schedule must be added.
- If a number of schedules are created it is suggested that they are timed to run at least 15 minutes apart.