Issue
Security Expert Smart Connector integration is working but Alarms states are not updating, the following error is appearing in Smart Connector logs:
2021-01-07 15:19:22.2621,Info,Processor,<no principal>,Validation Prompt for Security Expert Alarm Update Processor: MayNotContinue : The EwsServer was not located or the credentials you supplied were incorrect. Please verify your credentials and try again.
Product Line
EcoStruxure Security Expert
Environment
Smart Connector
Cause
It appears that the SOAP credential within the Security Expert Discovery Processor does not match the credential within the Security Expert Client SOAP operator credential.
This is a known issue where the credential does not update when changed/edited within the Processor Configuration of the Security Expert Discovery Processor configuration.
Resolution
A workaround is to log on to your local Smart Connector portal and edit the credential value within: Setup/Processor Values/SecurityExpertSettings
Change the username and password as required here.
Then save and the new credentials should be updated.