Issue
When trying to create or update a Security Expert database the error 'Invalid Database Server is displayed
Product Line
EcoStruxure Security Expert
Environment
- EcoStruxure Security Expert
- Microsoft SQL Server
Cause
The path to the SQL Server from the Client is incorrect or inaccessible and will not resolve
Resolution
There are a number of resolutions to this issue depending on the cause. This article mainly focuses on a configuration where the Security Expert and Microsoft SQL Server are on separate PCs. The error can happen locally also but is less likely. One or more of these resolutions may be required to fix the issue.
1. The Server / Instance name is incorrect when typing it into the Database Server dialogue box during installation.
(Local SQL Server) Default Database Server Dialog Box
There can be some confusion on what to enter into the dialogue box because, by default, the instance name and the main database name are the same.
Ex. Server Name\Instance Name Database
localhost\SecurityExpert Security Expert
(Remote SQL Server)
Ex. Server Name\Instance Name Database
SVR19SQL19\SecurityExpert Security Expert
Note: If just the ServerName SVR19SQL19 or SVR19SQL19\SecurityExpert\Security Expert
The Invalid Database Server error would occur
Copy and Paste the Server and Instance Names using SQL Management Studio (SMSS)
This method can help to avoid typing errors
Install SMSS on the same PC that has Security Expert Installed or use SMSS on the SQL server with Remote Desktop
From the Connect to Server dialog> Server name, select <browse for more...>
Select Network Server and then select the remote SQL server and click OK
Right Click> Copy on the blue highlighted server name and instance
Paste into the Security Expert Database Server Dialog box
For a detailed description of Instanced and Database, click on the following link
Microsoft Database and Instance Article
Note: Try using the IP address instead of the SQL server name.
2. Make sure SQL Server Service is running on the remote SQL server
3. If using a named instance, make sure the SQL Server Browser Service is running on the remote SQL Server
4. Ensure Firewalls have an open port for SQL server (default 1433)
5. Make sure the SQL Server is configured to allow remote connections
6. The Windows account being used to do the Security Expert Installation must have access to create the database on the remote SQL Server.
7. Check the Windows Application and System logs on the Security Expert and SQL Server for errors related to the Security Expert Install, DNS or Connection errors
8. Examine the SQL Server Log for error messages
Ex. If Active Directory is being used, the error “The SQL Server Network Interface library could not register the Service Principal Name (SPN)”
This issue can be fixed by giving the domain account the appropriate permissions in Active Directory.
Permissions required are:
ServicePrincipalName: Read
ServicePrincipalName: Write
Log in to the server running your Active Directory service and execute the following steps:
- Run Adsiedit.msc
- In the ADSI Edit snap-in, expand Domain [YourDomainName], expand DC= RootDomainName, expand CN=Users, right-click CN= [YourAccountName, and then click Properties.
- In the CN= AccountName Properties dialog box, click the Security tab.
- On the Security tab, click Advanced.
- In the Advanced Security Settings dialog box, select one (any) of "SELF"'s row
- Click Edit, Open Permission Entry dialog box.
- Make sure the Principal is "SELF", Type is "Allow" and "Applied to" is "This Object Only", in the Properties section, select the properties below:
- Read servicePrincipalName
- Write servicePrincipalName
Click OK to apply all changes and exit the ADSI Edit snap-in
Finally, you need to restart the SQL Service(s) that use the account in question.
9. If you are still unable to get passed the "Invalid Database Server' error, please open a case with Technical Support.