Issue
Troubleshoot Security Expert Controllers showing offline in the client.
Product Line
EcoStruxure Security Expert
Environment
Security Expert
Cause
Require some common troubleshooting steps to help determine why controllers may be offline to the client.
Resolution
- Refer to the Troubleshooting Security Expert Controller Connectivity - Application Note on Exchange.
- If a controller has failed and the Replacement controller unable to be brought online then check if controller encryption had been enabled on the replaced controller.
- Restart the client software.
- Power restart the controller.
- Remove power
- Wait for all LED's on the controller to go completely off
- Apply power to the controller.
- In the controller web interface, on the Settings page, check that Event Server 1 has the
correct IP address. - Check that the Firewall is disabled. Check any Anti-Virus Firewalls/settings as well.
- If the Firewall cannot be disabled, ensure that all required ports are open between devices. See SX-SRVR Security Expert - Network Administrators - Installation Guide for details.
- Restart the Security Expert services under the PC's Services option in Control Panel. These need to be restarted when any changes are made.
- Confirm that the User Interface, Data Server, Event Server and Download Server module versions are all the same. Go to About > Version and check there. If the database has not been upgraded to the same version as the client software, then this can cause communications issues.
- On the Security Expert Server check that MSMQ is installed as this is now a requirement Security Expert MSMQ is required (Not showing live point status / shows "Unknown Status" error)
- If MSMQ was installed after Security Expert, you'd need to reinstall Security Expert to allow it to run correctly.
- If MSMQ is installed and controllers are still not coming online (or the controllers are "bouncing" offline/online) then anecdotal evidence suggests enabling Windows 8 Compatibility Mode may help especially for Windows Server 2016 and Server 2019. Set the Windows 8 Compatibility Mode checkbox in the Properties page for C:\Program Files (x86)\Schneider Electric\Security Expert\SecurityExpertEvtSvr.exe
- Under Global > Download Server confirm that your computer name is the name of the PC where the download server service is running.
- Under Global > Event Servers ensure that the computer name is the name of the PC where the event server service is running.
- Under Sites > Controllers confirm the Serial number, IP Address, Download Port, Download Server and Control and Status Request Port match what is set in the controller's configuration web page (browse to the controllers IP Address to view).
- On that same General tab go to Diagnostic Windows and open the download and event server windows. Review the information contained and if there are any errors shown.
- Right click the controller and select Get Health Status. Review the status messages displayed.