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Running reports on Extended Logs shows no data

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Running reports on Extended Logs shows no data

Picard Product_Support
‎2018-09-06 02:42 PM

Issue

Running reports on Extended Logs shows no data

Environment

Continuum system

Cause

Possible Causes:

  • Other programs currently running extended logging (pre-1.7x style).
  • Time sync errors
  • Cyberstation preference is set to false

Resolution

  1. Check that you do not have programs running that are performing extended logging the pre-1.7x style. Any programs that were used for extended logging should be disabled or removed.
  2. Check the Continuum Error Log listview and see if there are time sync errors. A difference of more than 5 minutes between the Master controller and the Cyberstation will stop extended logging from working properly. You will see an error indicating that the time difference has been exceeded.
  3. Ensure the Cyberstation preference is set to True
    Download Extended Log Data from Controllers on the LAN(RAS)
    If it was set to false, Stop/Restart Continuum

Run List views of all points, (inputs, outputs, numerics)
Example:

  1. In Explorer, Go to ListView> Listview_Infinity Inputs > Edit
  2. Click Columns> Add a Column
  3. Add ExtLogEnable
  4. Check Off Edit box
  5. Click Apply then the General Tab
  6. Run the listview
  7. Select Edit> Select All
  8. Select Object> Set Attributes
  9. Select ExtLogEnable, For Value type in True and Click OK, OK
  10. Select View> Refresh list and the attributes are set to true
  11. Repeat this for Outputs and Numerics
  12. Wait for awhile beyond how often you are logging your points.
  13. Run reports to verify data is being logged.

NOTE: Occasionally, after an upgrade, you may need to set all the extended log enable attributes to FALSE FIRST and then to true again for inputs, outputs and numerics to get them working.

Data may have been logging and then stopped. The data range requested in the report doesn’t have data, but there is data in the database. Here are some tips on verifying the data in the database.

Using Enterprise Manager

  1. Use Query Analyzer against the Continuumdb
  2. Select * from extendedlog

Using OSQL

  1. Go to a command prompt
  2. Enter in osql –Uandover97 –Ppyramid97 –S then enter (this assumes default user and pw, change if needed. –S needs to be followed by your server name Once you hit enter you’ll be brought to the 1> prompt
  3. At the 1> Prompt hit the Enter key
  4. 1> select * from ExtendedLog
  5. Type Go the Enter
  6. If values are returned, then extended logging is working.
  7. Type quit (to exit OSQL)
  8. Type Exit to close the DOS window
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