Issue
When clicking on the Right Click Menu for I/NET Converted TGML Graphic on remote SmartStruxure Workstation, nothing happens even though I/NET has already been installed on this computer and I/O server has been registered as service.
Environment
SmartStruxure
I/NET Seven 2.44a through to 2.48
Remote Workstation
Cause
On a 32 bit OS and a 64 bit OS machine, the I/NET Converted TGML Graphic are different because I/NET default software installation path is different:
32 bit OS: C:\Program Files\INET Seven\
64 bit OS: C:\Program Files (x86) \INET Seven\
Since the Right Click Menu calls the I/NET program, if the graphic is converted on 64 bit OS machine on the Server, it will not work on the Client machine with 32 bit OS. And vice versa.
Resolution
NOTE:
This right click menu option will only function when the graphics page is located on an Enterprise Server where a copy of I/NET is installed on the local Workstation. This feature provides access to graphic functions run using the installed I/NET software so will not work when that software is not locally available. It is therefore not available when using WebStation or when viewing graphics located within a SmartX Server.
From I/NET version 2.49, this right click menu option will be removed from this editor and NO LONGER be available.
there are mixed versions of 32 bit OS and 64 bit OS between ES and Remote Workstation, the I/NET graphics need to be converted on 64 bit OS machine. And then follow the steps below:
1. Manually create C:\Program Files (x86)\INET Seven\ folder on 32 bit OS machine.
2. Uninstall I/NET and reinstall it under the folder created instead of default one.
Then the Right Click Menu should work now.