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Report objects being emailed using the ReportCmdLine.exe application do not get sent properly and the attachments are unreadable.

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Report objects being emailed using the ReportCmdLine.exe application do not get sent properly and the attachments are unreadable.

Picard Product_Support
‎2018-09-10 08:57 PM

Issue

Report objects being emailed using the ReportCmdLine.exe application do not get sent properly. The emailed attachment is unable to be opened as a PDF or Web object.

When the same report is being saved to file, the resulting file is readable. When the same report is being email from the Report objects Email button, the resulting attached file is readable. Only when the ReportCmdLine.exe program is used to send an email attachment of the report does this fail. 

Environment

Continuum Cyberstation v1.81

Microsoft Outlook

Cause

This is a defect in the original Continuum v1.81 Hotfix that this BETA hotfix resolves.

Resolution

Install this new BETA patch (now included a new Util.dll and Reportviewer.exe files) into your Continuum folder using the below method for both files. Find the patch here.

  1. Shut down CyberStation(s)
  2. Copy the existing file reportviewer.exe in the Continuum directory to another file so you now have a new file named "copy of reportviewer.exe".
  3. Delete the original reportviewer.exe.
  4. Copy the new reportviewer.exe file from the hotfix archive to the Continuum directory.
  5. Copy the existing file Util.dll in the Continuum directory to another file so you now have a new file named "copy of Util.dll".
  6. Delete the original Util.dll.
  7. Copy the new Util.dll file from the hotfix archive to the Continuum directory.
  8. Restart the CyberStation(s)

You should now be able to view the email attachments both in PDF and Web format.
 

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