Issue
The Exchange Download Center contains all of the assets you once accessed through the Buildings Extranet are now available on a brand new platform. It's easy to search and fast to download. Stay tuned for more great features as we roll this into the all-new extranet solution for Buildings. We ask that you register for a new account on The Exchange.
Product Line
Andover Continuum, EcoStruxure Building Expert, EcoStruxure Building Operation, Field Devices, Other, Pelco, Satchwell MicroNet, Satchwell Sigma, TAC IA Series, TAC INET, TAC Vista
Environment
Exchange Download Center
Cause
You can utilize the new Buildings web experience from The Exchange.
Resolution
- Navigate to https://ecoxpert.se.com/
* Use a modern browser for the best experience: Google Chrome, Mozilla Firefox, Microsoft Edge, and Microsoft Internet Explorer version 8 or later. If you receive the following error in Internet Explorer despite using version 8 or later, the browser displays the page in Compatibility View. Click here for more information on Compatibility View and how to disable it. The Download Center will not function properly in Compatibility View.
- On the header bar, you will see the option in the top right corner for “Login / Register.” Click it.
- If you are already registered, enter your email address and password. If this is your first time registering, click the link for “New to the Download Center? Register here!”
- Answer whether or not you are a Schneider Electric employee using the radio buttons.
- If you are a Schneider Electric employee, enter your SESA ID and your desired password for The Exchange. Click to accept Schneider Electric’s Terms and Conditions and hit “Create Account.”
* The first time you register, you must be connected to the Schneider Electric network or connected via VPN. This is only required at registration. All future logins can be done externally. - If you are not a Schneider Electric employee, enter your first name, last name, company name, location, business email address, and desired password for The Exchange.
* It is important to use your business email address if you are a licensed partner. Your email address is used to automatically validate your Partner status and assign the correct permissions to your user profile.
- If you are a Schneider Electric employee, enter your SESA ID and your desired password for The Exchange. Click to accept Schneider Electric’s Terms and Conditions and hit “Create Account.”
- An email is sent to your designated inbox with a link to click through and validate your email address. Once this is done, your login is created, and you are ready to start using the Download Center.
* If an error is displayed when trying to validate your authentication code, please try to log in. This happens when an email address has already been verified and oftentimes does not indicate an error with the registration.
Once logged in, you can search and download assets available to your user profile. If you attempt to download a file that you do not have access to, you will be given a chance to report if this is in error.
Your username, email, and the asset you are trying to access are recorded. Please enter a message if any further description is required and hit “Submit.” A member of our team will get back to you promptly with a resolution.
Web Site Support
For any issue regarding The Exchange Download Center, please contact us at exchangesupport@schneider-electric.com.