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Receive the following error message within I/NET: Default system page: File does not exist!

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Receive the following error message within I/NET: Default system page: File does not exist!

Picard Product_Support
‎2018-09-10 12:10 AM

Issue

Receive the following error message within I/NET:  Default system page: File does not exist!

Environment

I/NET Seven all revisions

Cause

  1. Under the Host Configuration Editor there is a setting for the Default system page.  The path and filename in this section must be correct.
  2. One or more points on a graphics page have the check box for Automatic page and / or Home Page options checked in their property settings when added to a graphics page.  (See boxed section below):

     
    I/NET generates the above error when the alarm is triggered and this setting has been checked.  The other instance that generates the error is when selecting the Home Page option from within AMT, either by right-clicking on the point in alarm or using the Home Page icon . 

    The error is generated because the original graphics page has now been moved, renamed or deleted from its original state when these points were added to the graphics page.  This causes I/NET not to find the graphics page and hence display the error.

Resolution

 To remove this error check the following two possible causes:

A.  Host Computer Configuration - Default page setting incorrect:

Ensure that the Host Configuration is pointing to the correct path / filename for the default graphics page.  This is achieved as follows:

  • Log in to I/NET
  • Go to Edit > Host Computer > Configuration
  • Within the Host Computer Configuration editor check within the Monitor section that the Default system page (as shown below) is valid.  If not use the browse button [...] to locate the default page you wish to use.
  • Select the correct page, click Open then click OK to close the editor.
  • Log out and back in to check that the correct page opens.

B.   Home Page / Automatic Page display references are invalid:

The resolution for this can be done in two ways: 

1. Modification of Home Page references
Note this method can not be used if the page has been deleted. 
If you know or have some knowledge of which pages have been changed, then you can modify the path by editing a file as follows: 

  • Locate the I/NET Seven Data folder, by default this is located in "C:\INET Seven Data\Data" 
  • This folder should contain a file called:
    • HOMEDIR
  • Using a text editor open this file and carefully locate the relocated path and modify these entries (Note their may be multiple entries of the same graphics page).
  • Save the file and confirm the Home Page or Automatic Page display option now works.
  • If this does not work then the only solution is to recreate all the home page references as described in the below procedure. 

2. Recreating all references to Home Page points:
If the page names are not known or the graphic page has been deleted then the above process may assist to locate other graphic pages which have Home Page references, making this process somewhat shorter.  This method will correct the error by re-creating all links to the Home Page / Automatic Page display used within your I/NET system. The steps for this are as follows:

  • Locate the I/NET Seven Data data folder, by default this is located in "C:\INET Seven Data\Data"
  • This folder should contain two files called:
    • HOMEDIR
    • HOMEPAGE
  • Delete these two files
  • Now edit each page via the Graphics Editor and save each page.  The saving process will recreate the references to these pages back into the above file names. Note: If the graphics pages with references are known then you only need to visit those graphics pages; if not then all graphic pages will need to be edited / saved to ensure all references are re-created.
  • Test its operation to confirm this process has functioned as expected.

If the problem still persists then please email Product Support with the Graphics, SAV files along with the HOMEDIR & HOMEPAGE files mentioned above.

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