Issue
Personnel.csv file fails to import into Continuum
No error message is shown
Product Line
Andover Continuum
Environment
Continuum access control
Keywords: CSV, Import, cardholder, personnel
Cause
CSV file gets modified by MS excel such that the import fails
During the process of manually changing and saving a personnel.csv file within MS excel, a number of commas are added to the first line (corresponding to the number of column fields in the CSV)
Resolution
Use notepad or similar to delete commas before importing into Continuum as Microsoft Excel does not show up any trailing commas
This will NOT import correctly
Personnel,,,,,
Name,FirstName,LastName,CardNumber,CardType,SiteCode
Smith_Fred,Fred,Smith,10,Infinity_37,3701
This will import correctly
Personnel
Name,FirstName,LastName,CardNumber,CardType,SiteCode
Smith_Fred,Fred,Smith,10,Infinity_37,3701
For more information on CSV imports Click Here
For an example .csv file for testing Click Here
Note: If importing X Driver points using a .csv file the comm port attribute "Port" must always be defined before the X Driver parameters Param1, Param2 etc. The Port must contain the full path e.g. "Network1\CXName\Comm1"
Example X Driver Numeric:
InfinityNumeric
Name,Alias,Format,Description,Port,Param1,Param2,Param3,Param4
XDRPoint1,XDRPoint1,##,First X Driver Point,Network1\CX1\comm4,1,3,10001,1