Issue
TAC Vista reports an error in the Alarm view that no more threads can be created and remote workstations cannot connect to the Vista server.
Product Line
TAC Vista
Environment
TAC Vista Workstation
Cause
This issue occurs when the TAC Vista remote computer that connects to the TAC Vista Server computer is left logged in and the Remote computer goes into hibernation.
This causes the TCP/IP Thread between the TAC Vista remote computer and the TAC Vista server PC's to remain in use.
Then once the TAC Vista remote computer is taken out of hibernation another TCP/IP Thread is created.
Eventually this will use up the allocated thread count and generate an error.
Resolution
- Restarting the TAC Vista Server PC will fix the issue until the TCP/IP Thread count increase to the limit again.
- The TAC Vista Remote Workstation computer can be setup so it doesn't go into hibernation and remains on, then the TAC Vista log off function works correctly and closes down the TCP/IP Thread.
- Alternatively change the TAC Vista Remote Workstations to TAC Vista Servers and configure them to look at the mastern TAC Vista server. This configuration uses a different communication setup for Server to Server communications. See the Creating TAC Vista multi-server network Knowledge Base article for further information on this configuration