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Moving the WebReports SQL database to another hard drive

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Moving the WebReports SQL database to another hard drive

Picard Product_Support
‎2018-09-06 09:06 AM

Last Updated: Guinan RobertAndriolo Guinan ‎2019-06-12 07:25 PM

Warning

Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support Services for assistance.

Issue

The database files used by the WebReports SQL database need to be moved to another location.

Product Line

EcoStruxure Building Operation

Environment

  • WebReports
  • SQL Server

Cause

There are numerous reason for wanting to do this, but the most common reason is that there is not enough space on the disk where the WebReports databases are located. By moving to another disk this will allow space for future expansion.

Note that this article only describes how to move the database files to another harddrive. The SQL server and database files must still be on the same PC where WebReports is installed.

Resolution

To move the database files, follow this process:

  1. Start by backing up everything.
  2. Stop the reporting agent service (name: ReportingAgentService).
  3. Open SQL Server Management Studio and locate the database.
  4. Right-click on the database and select Tasks-->Detach.
  5. Locate the SQL database files (*.mdf and *.ldf) in Windows explorer.
  6. Cut or copy these files and move them to the desired location.
  7. Go back to SQL Management Studio and select the Databases folder.
  8. Right-click and select Tasks-->Attach database.
  9. When the dialogue opens up, locate the 'ADD' button and click on it.
  10. Browse to the database files' new location and click on OK.
  11. Restart the reporting agent service.
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