Issue
- Data not passing from Enterprise Server to Reports Server after upgrading to 1.6
- Reports folder does not appear on new 1.6 Reports installations
- Logon failed at attempt no. XX User account has been temporarily disabled. Contact your administrator.
Product Line
EcoStruxure Building Operation
Environment
Building Operation WebReports 1.6 and above
Cause
New features require additional configuration to allow Reports to function. Specifically, the Reports installation requires that the SystemReportsService user account be enabled before installation. If this is not done, the steps below must be taken.
For Issue #3:
If the user account used to access WebReports is changed through WorkStation, WebReports is still using the previous account password to access the Enterprise Server, this will lock the user account out and if used to log in to WorkStation will indicate that the account is disabled
To verify that this is what is causing the lockout, open the Report Agent log StruxureWareReportingAgentLog and check for Logon Failed at attempt xx Reason: User account temporarily disabled.... error is shown.
The default path for this log file is:
C:\Program Files (x86)\Schneider Electric (StruxureWare)EcoStruxure\Building Operation
Resolution
During the installation of WebReports, you will see the popup message below. In order for the installation to work correctly, the SystemReportsService account must be changed to enabled before clicking OK.
Ensure that SystemReportsService user account is enabled in the Enterprise Server before you proceed with the installation process further.
To correct this error after installation:
- If running stop the Repot Agent Service and wait 1 minute before proceeding
- Log into Workstation using the admin account
- Modify the user "SystemReportsService" (or user account used) that is part of the Local domain
- Check/Change the property "Disabled" is set to "False
- Change/verify the password
- Close WorkStation
- On the Report Server open the program "Building Operation WebReports Administrator"
- Enter the newly created password for the SystemReportsService (or account used)
- Click Apply - a successful update should be reported.
- Click Save
- Close Building Operation WebReports Administrator
- Restart the Reporting Agent Service.
- Verify logins now work.
For additional Authentication issues please see the online help topic: Authentication Failed (se.com)