Issue
The first time a WB-profile user connects a web browser to an I/A Series G3 station, the user is prompted to download software from Oracle.
Product Line
TAC IA Series
Environment
I/A Series G3 (AX), version 3.8.xxx
Cause
An earlier version of I/A Series G3 used an open-source library for 128 or 256-bit encryption. I/A Series G3 version 3.8.xxx migrated to the Java Cryptography Extension (JCE) that requires the installation of add-on files from Oracle.
Resolution
Download the required files from Oracle.
Depending on your version of Java, download either ...
JRE8 ... http://www.oracle.com/technetwork/java/javase/downloads/jce8-download-2133166.html
JRE7 ... http://www.oracle.com/technetwork/java/javase/downloads/jce-7-download-432124.html
Otherwise, navigate to the Oracle download website and search for the links to "Java Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy Files" for your Java version ...
http://www.oracle.com/technetwork/java/javase/downloads/index.html
- Accept license and download. This may require registration or sign in to Oracles website.
- Locate the Correct Java Folder on Your PC Where the Software Must Be Installed. Launch... Windows > Control Panel > Java
- In the Java Control Panel, navigate to the "Java" tab, and then click "View" to see the installed Java version.
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The name of the folder where Java is installed precedes the "bin\javaw.exe" in the text. "JavaHome" is what this document will call that folder, no matter what the full name is.
In the example below, the folder name appears as "C:\Program Files\Java\jre?" -- the obscured last character will be 7, or 8, or some other number, depending on the installed Java version.
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Install the Files on Your PC
Use Windows (File) Explorer to navigate to the Java jre folder path as shown in the step above. From the jre folder, navigate to the lib\security\ folder. Copy the local_policy.jar and US_export_policy.jarfiles contained in the Oracle download and replace the older version files.
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Clear the web browser's cache
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Delete the contents of the C:\Users\username\niagara folder.
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Clear the java cache (Control Panel => Java => Temporary Internet File "Settings" => Delete Files => check installed apps and applets => OK
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Re-start the web browser
NOTE: This procedure will need to be performed on each computer accessing the I/A Series G3 station via a web browser.