Issue
Niagara 4.9 (or later) sometimes has a new Host ID that differs from the Host IDs of other versions of Niagara that were installed on the same host PC
Product Line
TAC IA Series
Environment
I/A Series N4 Enterprise Server
Cause
Niagara 4.9 and later, are only available in a 64-bit version. The older Niagara versions installed on the host PC are probably 32-bit versions, which will always have Host IDs different from 64-bit versions.
Resolution
If the older versions are Niagara 4.3 or lower, you may need to update the older versions, as per the following document…
I/A Series G3 and N4 Eliminating multiple HostID on a single PC
Niagara 4.9 (or later) is only available in a 64-bit version. The other Niagara versions installed on the host PC are probably 32-bit versions, which will always have Host IDs different from 64-bit versions. In this case, the host PC will require one of the following
- Un-installing the 32-bit versions and re-installing 64-bit equivalents
- One license, to be "transferred" to a different Host ID when necessary
- Multiple licenses, one for each unique Host ID.