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I/A Series R2 Enterprise Server station is unable to connect to the SQL database

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I/A Series R2 Enterprise Server station is unable to connect to the SQL database

Picard Product_Support
‎2018-09-10 02:33 AM

Issue

I/A Series R2 Enterprise Server station is unable to connect to the SQL database

The following errors are seen in the Enterprise Server station's Standard Output:

  • ERROR: Could not open database connection [/SQL2005/services/DatabaseService]
  • java.sql.SQLException: Charset 0x0904D00031/Cp850 is not supported by the JVM.

"The program can't start because MSVCR71.dll is missing from your computer. Try re-installing the program to fix this problem."

Environment

I/A Series r2.301.529

SQL Server 2005

Java Runtime Environment 1.6

Cause

JRE 1.4.1 which I/A Series R2 uses does not know how to support the CP850 character set.

Even though the computer has been installed with JRE 1.6, I/A Series R2 is still using JRE 1.4.1.

Resolution

To enable I/A Series R2 to use JRE 1.6, follow these steps:

  1. Download and install JRE 1.6 if it has not been already installed. The latest version can be found here http://www.java.com/en/download/manual.jsp.
  2. Go to Windows Services and stop the Niagara service.
  3. In Windows Explorer, go to \niagara\r2.301.529\nre\ and rename the 'jre' folder to 'jreold'.
  4. In Windows Explorer, go to C:\Program Files\Java (this is typically the path of the Java install). Copy the 'jre6' folder including its contents and paste it to the \niagara\r2.301.529\nre\ directory.
    Rename the 'jre6' folder to 'jre'.
  5. In Windows Explorer, go to \niagara\r2.301.529\nre\lib and open the 'nre.properties' file using a text editor program (eg. Notepad). Comment out the 'java.options...' parameter. Add the parameter shown below, save and close the file. Start the Niagara service and run the station. Check in the Standard Output window to see if the error has been cleared and that the DatabaseService has successfully connected to the SQL database.

    ########################################################
    #
    # File:  nre.properties
    #
    #    NRE properties
    #
    # Revision History
    #   21 Aug 03   Brian     Original version.
    #
    ########################################################

    # Virtual machine to use: jview|hotspot
    vm=hotspot
    #vm=jview
                         
    # List of Java options to pass thru to the VM (hotspot only)
    # Used with original install 1.4.1
    # java.options=-Xmx1024MB

    # List of Java options to pass thru to the VM (hotspot only)
    # USed with 1.6
    java -Xmx1G

 

Notes:

  • This solution can be applied to a similar error but with a different charset encoding error other CP850.
  • You may encounter the following error when you try to run WorkPlace Pro after performing this fix.

"The program can't start because MSVCR71.dll is missing from your computer. Try reinstalling the program to fix this problem."

To resolve this, go to \niagara\r2.301.529\nre\jre\bin and locate the file MSVCR71.dll. Copy this file to the C:\WINDOWS\system32 directory.

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