Issue
I/A Series G3 Workbench License Manager build 3.8.37 will not automatically import from the License Server even when the connection to the Internet is active. The result is the display of the Request License dialog box that provides the host ID and email information for Schneider Electric.
Product Line
TAC IA Series
Environment
I/A Series G3 Workbench 3.8.37
Cause
The issue is related to a setting within the brand.properties file included with the 3.8.37 install. This setting enables or disables the online license server request function within Workbench. The setting was inadvertently set to disabled (false).
Resolution
The issue can be easily resolved by changing the setting by one of the two methods shown below.
Method 1 - Replace existing brand.properties file with an updated version
- Close Workbench
- Download the following zip file with the updated brand.properties file > brand.properties
- Use the Windows Explorer and navigate to the lib directory under the niagara-3.8.37 directory
- Extract the updated file from the zip and replace the existing brand.properties file
Method 2 - Manually edit the brand.properties file
- Close Workbench
- Use the Windows Explorer and navigate to the lib directory under the niagara-3.8.37 directory.
- Open brand.properties using a text editor such as Notepad
- Carefully edit the following line changing the false to true: license.onlineRequest=false ... update to license.onlineRequest=true
- Save the file
Workbench will now import licenses from the license server.