Issue
Unable to send emails using Google's SMTP Server
Product Line
EcoStruxure Security Expert
Environment
- Security Expert Server
- Security Expert Controllers (SP-C-WEB, SP-C)
- Google SMTP Server
Cause
SMTP server settings in Controller and/or Google account settings are incorrect.
Resolution
- When configuring the Email SMTP settings under Global | Global settings confirm that the correct SMTP server address and settings are used:
- SMTP Mail Server: smtp.googlemail.com
- SMTP Port: 25
- Use SSL: Enabled
- SMTP login: <your Google account>
- SMTP password: <the app password created in section below>
- Google has removed the "less secure app access" ability and replaced it with "app passwords" where you create a unique 16-digit passcode for each individual app requiring access. See details on how to Sign in with app passwords.
- To use app passwords Google requires the account to be setup for 2-Step Verification.
- If you do not see the App passwords item under your Google accounts Security section you can also find this by typing "app passwords" in the "Search Google Account" search bar at the top of the window, select the first item "App passwords".
- In App passwords press Select app and choose Other (Custom name). Add a descriptive name for the app and click GENERATE. Copy the resulting 16-digit passcode as this will be the passcode used for the SMTP server credentials.
- Ensure Firewall settings are not blocking access to the mail server, especially if the McAfee firewall is being used. If there is a Firewall try temporarily disabling this to test.