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How to send SMTP mail from command prompt for testing

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How to send SMTP mail from command prompt for testing

Picard Product_Support
‎2018-09-11 07:28 AM

Issue

When troubleshooting SMTP email issues it is oftentimes handy to send a test email directly from Windows in order to narrow down the part of the system with the problem.

Product Line

Andover Continuum, EcoStruxure Building Operation

Environment

  • Windows
  • Continuum
  • SmartStruxure

Cause

Troubleshooting technique.

Resolution

Simple way to test SMTP email for testing purposes.

  1. Make sure telnet is turned ON in Windows. (If not, go to Control Panel > Programs > Turn Windows Features On or Off > turn ON the Telnet Client.)
  2. Open a command prompt and type telnet domain name (or IP address) and port.
    telnet 10.169.9.10 25​
  3. Type HELO and identify the sending system
    helo MyPCName​
  4. Type mail from: followed by an email address
    mail from: user@tac.com​
  5. Type rcpt to: followed by destination address. (NOTE: must be an email account in the mail server)
    rcpt to: user@3indq.com​
  6. Type data then ENTER key
  7. Type a message
  8. Type . (period) then ENTER to end

NOTE: Type slowly and if you mistype something hit enter and after the error re-type the line. Using backup space appears to work but it doesn't.

NOTE:

  • Make sure Telnet server is installed on the SMTP server.
  • Make sure Telnet service is enabled/running on the SMTP server
Labels (2)
Labels:
  • Andover Continuum
  • EcoStruxure Building Operation
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