Issue
When troubleshooting SMTP email issues it is oftentimes handy to send a test email directly from Windows in order to narrow down the part of the system with the problem.
Product Line
Andover Continuum, EcoStruxure Building Operation
Environment
- Windows
- Continuum
- SmartStruxure
Cause
Troubleshooting technique.
Resolution
Simple way to test SMTP email for testing purposes.
- Make sure telnet is turned ON in Windows. (If not, go to Control Panel > Programs > Turn Windows Features On or Off > turn ON the Telnet Client.)
- Open a command prompt and type telnet domain name (or IP address) and port.
telnet 10.169.9.10 25
- Type HELO and identify the sending system
helo MyPCName
- Type mail from: followed by an email address
mail from: user@tac.com
- Type rcpt to: followed by destination address. (NOTE: must be an email account in the mail server)
rcpt to: user@3indq.com
- Type data then ENTER key
- Type a message
- Type . (period) then ENTER to end
NOTE: Type slowly and if you mistype something hit enter and after the error re-type the line. Using backup space appears to work but it doesn't.
NOTE:
- Make sure Telnet server is installed on the SMTP server.
- Make sure Telnet service is enabled/running on the SMTP server