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How to clear the error log in the Continuum controllers.

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How to clear the error log in the Continuum controllers.

Picard Product_Support
‎2018-09-06 10:45 AM

Last Updated: Administrator CraigEl Administrator ‎2024-05-12 06:55 PM

Issue

For various reasons sometimes it is necessary to clear the error log in the controllers.

 

NOTE: First generation controllers such as the CX9200 and CX9900 (NetController 1) and Infinet1 devices do not support the error log utility, this article does not apply to those controllers.

 

Product Line

Andover Continuum

Environment

  • CyberStation
  • bCX9640
  • bCX4040
  • bCX4000
  • CX9680
  • ACX5740
  • ACX5720
  • All b3 devices
  • All i2 devices

Cause

Guidelines for clearing the controllers error log in the field.

Resolution

bCX4040, bCX4000, b3s

Error log is cleared by setting the Errors system variable to 0 (zero)

 

IMPORTANT

It s not recommended to set the errors system variable from within a Plain English program, doing so risks damaging the controller's flash memory which has a limited number of write/erase cycles. Only reset the errors system variable to 0 from the command line or from the system variable object editor.

 

If the Errors system variable has a non zero value all that is required is to reset it to 0

 

NOTE:

In some older version of the firmware, if the Errors system variable is at 0 then it has to be changed to a non zero value before it can be reset to 0

One easy way to generate an error is to create an InfinityProgram that attempts a DIVIDE BY ZERO

I.e.

Program is AutoStart and FallThru

Numeric N

n = 1/0

 

Create the InfinityProgram above in the controller, once the program saves and runs it will be disabled and the Errors system variable will increment by one.

Remember to delete the program as it is no longer needed


bCX9640 CX9680, ACX5740, ACX5720

Use the controller error log tool to clear the error log.

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  • Andover Continuum
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