Issue
The site has Alarm Action to email certain door alarm condition but only at a specific time of day and/or day of the week
Product Line
Access Expert
Environment
- Access Expert Hosted Software
- Access Expert Premise Software
Cause
Alarm actions do not allow association with a regular schedule, instead, the filter query can be used to specify a time and/or the day the action should take place.
Resolution
The screenshot below shows the schedule that the site wanted to use to specify when the action should be carried out...
Since we can not associate the schedule with the alarm action, we should instead specify the days/hours in the filter query using the following filter...
((EventData["Status"].AsString == "Activated")&&(((OccurredOn.Date.Hour < 17 && OccurredOn.Date.Hour < 4)&&(OccurredOn.Date.DayOfWeek == "Tuesday"|| OccurredOn.Date.DayOfWeek == "Wednesday" || OccurredOn.Date.DayOfWeek == "Thursday" || OccurredOn.Date.DayOfWeek == "Friday")) || (OccurredOn.Date.DayOfWeek == "Saturday" && OccurredOn.Date.Hour > 4)|| (OccurredOn.Date.DayOfWeek == "Sunday")||(OccurredOn