Issue
Since the Cloud Plugin cannot perform search operations on EBO, Building Advisor can only estimate the number of forced points using the event log and, for EBO versions above 3.2.1, the server archive.
Product Line
EcoStruxure Building Advisor
Environment
BMS Health
Cause
1. Incomplete Event Log: The event log may be incomplete if the maximum capacity is reached in EBO (events are rolling). When a customer connects their system, some historical events may be missed.
2. High Event Production: If a customer's system generates events at a higher rate than BA can process (currently, BA can ingest 100,000 events every 6 hours), some events may be overlooked, especially if there are many noisy events.
3. Understanding of Events: BA can only recognize forced and unforced events. BA will lose track of that point if an object's absolute path is updated or deleted instead of being unforced.
4. External Tools: BA cannot track it if an external tool forces a point without creating a corresponding forced/unforced event in EBO.
Limitations with EBO Versions 3.2.1 or higher:
Building Advisor can resolve issues for each server by retrieving snapshots from the server archive. This method can address the abovementioned issues, except for point number 4. Additionally, Bacnet points forced via commands are unavailable in the server archive, meaning we cannot retrieve those values through the Cloud Plugin.
Resolution
- Check the EBO Version, and If the customer's system is older than version 3.2.1, advise them to upgrade.
- Verify Server Archive, ensure the issue pertains to Bacnet points, and proceed to the next step. Ensure all servers associated with the mismatched forced items have an updated server archive. This will enable the Building Advisor (BA) to obtain the correct snapshots from the system. You can check this in the building's BA connectivity tab.
- If the servers are updated, proceed to the next step. If they are not, ensure that server backups are created periodically. You can check this in the BA architecture tab under the backup section.
- If a newer backup is present compared to the "Last Upload" in the server archive table, attempt to send it again. Refer to the instructions on how to send a new backup at the end of the file.
If there isn’t a newer backup, create one and send it. Important: Please note that it may take one to two days for the Building Advisor (BA) to reflect the updates. - If the object exists in EBO, retrieve the events from the relevant branch and filter for force-type events.
- If the last event is unforced and BA is showing as forced, Force it and then unforce it one time. If it was a Bacnet point, try to force it from the basic tab.
- Note: If you have multiple points, you can search using the appropriate criteria and perform all the force/unforce operations simultaneously.
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If the object no longer exists in the path, you can create a replica of the object in the same path and perform the force/unforce operation. Ensure that events are created for your actions (see Step 5).
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If the point does not exist for manual override and you cannot set a new device in the path, please open a PSS case.
- Send a new backup using the following process:
- Navigate to ~/System/Modules/CloudPlugIn/Statistics/Services
- Add the Service type and Server name columns in the list view
- Locate the Service Type of SystemDiscovery, multi-select the server(s) affected, right-click, and select Execute task now
- If the issue is unresolved two days after uploading the updated SystemDiscovery files, please open a PSS case.