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Extended trendlogs are cleared and cannot be started after a restore

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Extended trendlogs are cleared and cannot be started after a restore

Picard Product_Support
‎2018-09-06 03:10 PM

Issue

Extended logs are not retrieving new values after an automation server (AS) has been restored underneath the enterprise server (ES). The problem occurs when there is an enterprise server extended log referencing an automation server extended log that is referencing a Xenta log. 

Environment

  • Workstation
  • Extended Logs
  • StruxureWare Building Operation

Cause

If an AS extended log with historical data is restored (for example after the Xenta controller that contains the Xenta log comes back online) the AS extended log can become locked up and will not record new data.

When the Xenta controller goes offline and then comes back online the following sequence of events occur (Note: some values in this scenario are entered for example purposes only like the Xenta LogSize):

  1. After a restart of any kind the Xenta log will set its LastSeqNo to LastSeqNo+LogSize. This is to tell the AS extended log to do a read since it doesn't know if there are any new records; it should assume everything is new. (A key problem here is that the Xenta log will not increase its LastSeqNo until something reads from it. Normally when there is just an AS extended log and a Xenta log, the AS extended log reads and gets 3 records back. This makes everything go back to normal).
  2. The ES extended log notices that the AS extended log has been restored. The ES extended log sends a command to the AS extended log to clear the entire log and set the Last WrittenSeqNo to 101. This changes the scenario in event one from allowing the AS extended log to begin working properly.
  3. The AS extended log is only interested in new records now so it requests the LastSeqNo from the Xenta log. This value is used as the Last TransferredSeqNo in the AS extended log. When the AS extended log requests new records from the Xenta log, it answers 150 which is actually the LastSeqNo+LogSize. The Xenta log will not perform a real read to the external log to find out the actual LastSeqNo until something reads it and will not move beyond 150 because of the restart state it is in.

Summary: The AS extended log won't read until the Xenta log tells the AS extended log that it has a new record and the Xenta log won't check for a new record until something reads it.

Resolution

Use a Trend Chart with Live Update

The Xenta log can be opened in a trend chart with live update on. The chart will read every few seconds from the Xenta log causing the Xenta log to set its LastSeqNo to the value it should be. Given enough time the Xenta log will have reached the LastSeqNo where the AS extended log will start logging again.

To speed this process up, the interval on the Xenta log can be set to the fastest possible scan time (10 seconds). Once the AS extended log begins collecting values again, the Xenta log can be changed back to the original settings.

Note: The Xenta log will be cleared when changing the interval.

 

Create a New Extended Log

A new AS extended log that monitors the Xenta log can also be created to correct the problem (disconnecting the old extended log). The new extended log will start reading from the beginning and start working immediately.

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