Issue
After updating FireFox to version 34 and later, you get the message "Unable to Connect Securely" when accessing a Xenta Server using HTTPS
After updating Chrome to version 40 and later, you get the message "This webpage is not available" when accessing a Xenta Server using HTTPS
In Internet Explorer, you get the message "This page can't be displayed" when accessing a Xenta Server using HTTPS
Product Line
TAC Vista
Environment
- Xenta Server
- FireFox
- Chrome
- Internet Explorer
Cause
From version 34 of FireFox and version 40 of Chrome, SSLv3 is disabled by default for security reasons as SSLv3 is no longer considered secure enough. As per Vista Server Cryptographic Protocols TAC Vista, TAC Xenta Server and TAC Xenta 911 is using SSLv3 and is therefore blocked when using SSL (HTTPS).
In the newest versions of Chrome and FireFox, not even the work around described below works, so you need to set the Xenta Server to low security through the XBuilder project.
Resolution
In Internet Explorer, FireFox and Chrome you can manually reenable SSLv3.
Solution 1: Set the Xenta server to only use HTTP and not HTTPS
This is done in TAC XBuilder
Solution 2: Allow SSLv3 in FireFox
1: In the FireFox address bar, write about:config
2: Accept the warning
3: Write security.tls.version.min in the search field - below you can see the default setting
4: Double click the line, and change the number to 0
5: Try logging into the Xenta Server again. If it doesn't work the first time, restart the browser and try again
Check the advanced settings in Internet Explorer. SSL 3.0 must be enabled. If it's not, then enable it. If you can't, it's because it's disabled by a policy, and you need to get the IT department to enable it.
Solution 4: Allow SSLv3 in Chrome
1: In the Chrome address bar, write chrome://flags/#ssl-version-min and select SSLv3 in the drop down box.
Solution 2: Allow SSLv3 in FireFox
1: In the F