Issue
Enterprise Server does not start when computer is started/rebooted or shuts down right after starting it
StruxureWare Building Operation Software Administrator log shows the following error:
nsp.NspServer The server has made too many unsuccessful attempts to start...
Product Line
EcoStruxure Building Operation
Environment
- Software Administrator
- Enterprise Server
Cause
StruxureWare Building Operation is prohibiting the Enterprise Server from starting up because the ES has exceeded the number of startup retries defined in server_startup.properties.
When the server_startup.properties file is opened in a text editor, the first line indicates a startup failure.
NspServer.Startup.Service.Status: fail
Resolution
Windows XP: This is caused by a dependency, set in the registry, on the service netprofm (Network List Service), which exists on Windows Vista and later, but not on Windows XP.
The error has been verified on a new installation of Windows XP. Steps 1 and 2 below help to resolve this on the XP operating system.
Windows 7 and Windows Server 2008 R2 including Virtual:
- Start ES manually from the Software Administrator. If this fails, the log in the Software Administrator explains why.
- Start the ES manually from the Services listed in Services (Start, My Computer, right-click, Manage, Services click the + to find Services) find StruxureWare Enterprise Server
- Go to the Software Administrator and modify the HTTP, HTTPS, and TCP ports to available ports. (suggested: 81, 444, & 4444).
- The number of startup retries is defined in the following file:
1.2.0 and below : C:\Program Files\Schneider Electric\StruxureWare X.X\Enterprise Server\etc\server_startup.properties
1.3.0 : C:\Program Files\Schneider Electric StruxureWare\Building Operation X.X\Enterprise Server\etc\server_startup.properties
1.4.1 and above : C:\ProgramData\Schneider Electric StruxureWare\Building Operation X.X\Enterprise Server\db\etc\server_startup.properties
Increasing this threshold in server_startup.properties will allow the Enterprise Server to have a better chance of achieving a successful startup.
server_startup.properties -- Original settings
NspServer.Startup.Service.Status: fail
NspServer.Startup.Service.Status.NbrOfConsecutiveFails: 2
NspServer.Startup.Service.Status.QuitRetryAfterNbrOfConsecutiveFails: 2
server_startup.properties -- Threshold increase to 10 retries.
NspServer.Startup.Service.Status: success
NspServer.Startup.Service.Status.NbrOfConsecutiveFails: 0
NspServer.Startup.Service.Status.QuitRetryAfterNbrOfConsecutiveFails: 10
- Last option, and please go through all the previous steps mentioned before attempting: Open regedit and go to HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Building Operation X.X Enterprise Server. Open the DependOnService and remove the first line (netprofm) and then reboot. The ES will now start automatically.
Alternative Workarounds
- Go to Computer Management by right clicking on Computer and going to Manage.
- In Computer Management, go to Services and Application > Services > Building Operation X.X Enterprise Server. Right click on Building Operation X.X Enterprise Server and go to properties.
- The two different settings that can be changed so that the Enterprise Server starts automatically as a service after a reboot are as follows.
- Under the General tab, change the Startup type from Automatic to Automatic (Delayed Start).
- Or under the Recovery tab, change the Restart service after to a value of 3 or more minutes.
- Under the General tab, change the Startup type from Automatic to Automatic (Delayed Start).