Issue
Customer are running an ES with version 3.2.3 sending emails through SMTP server using TLS protocol.
After site is upgraded to version 4.0.3, emails are not sent and the following error is shown in the ES:
"SSL routines: tls_process server_certificate:certificate verify failed. Email service failed to connect to SMTP Server."
In version 6.0.3, the following error is also displayed in the ES:
"error:16000069:STORE routines::unregistered scheme"
Product Line
EcoStruxure Building Operation
Environment
- Building Operation Enterprise Server version 4.0.1 and later
- Building Operation Automation Server Premium (AS-P) version 4.0.1 and later
Cause
The following is stated in the EBO version 4.0.1 release notes:
"Certificate validation for SMTP When choosing TLS as encryption method (i.e. encryption of all traffic) for SMTP, then the certificate will be validated from EBO 4.0. If a corresponding CA-certificate isn’t present in the server, then a system alarm is generated. See more in “CA Certificate Management” ( also in section 2.17.5) how to import CA Certificate."
Resolution
In EBO version 4.0.1 and later a valid certificate needs to be installed if alarms should be sent when using TLS protocol in the communication to the SMTP server.