Issue
When evaluating Inet Transition sites, a common error seen when uploading I/NET controllers under the Inet Interface is an upload failure. The Background Status and trace log will contain a changeset error as shown below:
UploadDevice failed to process changeset on link: 93 station: 10, type index: 17 cannot continue upload
Product Line
EcoStruxure Building Operation, TAC INET
Environment
- Ecostruxure Building Operation
- Inet Interface
Cause
Understanding the ChangeSet Indices used by the developers will help pinpoint where the issue is originating from. The message typically isolates the Link and Station but does not identify where within this controller the problem may lie.
Resolution
The current list of ChangeSet Indices are listed below and attached Changeset_index.txt
Index Affected
9 DCU passwords, States, Eng units, Conversion Coeff., Controls, Holidays, DDC history, Override access, Sunrise/Sunset
11 Points
15 Action message, DCU DDC, Event sequences
17 Calculation
19 Event extension
21 Extension general (can be one of: Runtime, Consumption, or Alarm inhibit - depends on DCU type)
23 ATS
25 ATC
27 Extension application (can be one of: Demand, ORB, ORBEM, UC, LZ, LC, Elevator - depends on DCU type)
29 Trend
31 Lookup table (raw data)
33 Demand load (raw data)
35 MCU
37 MR DDC
39 AIC sequence (raw data)
43 LCD page, Istat param, IAS (raw data)
45 Access control (raw data)
Note: "raw data" indicates user cannot manipulate in EBO but it is uploaded and save in raw form to allow for a download/restore
- Working with the example shown in the Issue, the message indicates a changeset value of Index: 17.
- Using the attached list, Index 17 indicates that the issue is within the Calculation Editor.
- Using the SAV file from the site and working offline within I/NET open this SAV file and check each of the editors, in this case, calculations. In most cases, it will either be an invalid character or invalid point address - which will be shown as 'blank' as seen below:
- Correcting this and updating the SAV file to the controller (Station Restore) will typically correct this issue.
- If the same error persists then please provide an Export of the Inet Interface and the SAV files of the controllers having this problem through your local support channel.