Issue
Unable to determine why Users are being denied access at doors. Reviewing events shows that the Users are being denied access due to an Access Level that is not even configured to allow access to that door.
- User [UN1] Door not allowed [DR2] Using Access Level [AL1]
Product Line
EcoStruxure Security Expert
Environment
Security Expert
Cause
The user has no valid access levels for this door.
Resolution
The event showing like this is a side product of how access is validated.
- When a user badges at a reader, the card is first matched to a User record.
- Each of that user's access levels is then checked, from top to bottom, until either one is found to have access to the door, or all are checked and none have access to the door.
- If a valid access level is found then that is the access level shown in the Granted entry/exit event.
- If the user has only one access level and it is not valid for this door, the event will appear to be correct as that will be the access level name shown in the Door not allowed event.
- If the user has multiple access levels and none of them allow access to the door then the Door not allowed event shows the name of the last access level checked, which in all cases is the one from the bottom of the user's list of access levels.