Issue
The SmartX server has a "?" under the server name field and shows the error "SSL certificate validation failed!" as the server state in Device Administrator. In some instances, this may cause a failure to upgrade of the SmartX Server displaying these symptoms.
Product Line
EcoStruxure Building Operation
Environment
- Building Operation Device Administrator
- Building Operation Automation Server Premium
- Building Operation Automation Server Bundled
- Building Operation Automation Server
Cause
The SmartX Server is added into Device Administrator over HTTPS 443 but does not have a valid SSL certificate installed.
Resolution
- Change the connection from HTTPS 443 to HTTP 80
- This can be done by clicking into the server settings (click on the "?")
- Select "Edit Connection"
- Change the EBO Server Protocol from HTTPS to HTTP
- Create a trusted chain between Device Administrator and the problem SmartX Server using a self-signed certificate by following this workflow